DUO (2FA) - Supported Browsers

For Version: 

1.8.6

Duo Supports the following Browsers

Browsers (Chrome, Firefox, Edge, Internet Explorer 11 or higher, and Safari)

  • Support for IE users leveraging IE 8,9, and 10
    • If a user uses any of those browsers and they have Access Control enabled, Duo will block those older versions of IE!
      • To disable cross-origin access control go to Tools->Internet Options->Security tab, click on “Custom Level” button. Find the Miscellaneous -> Access data sources across domains setting and select “Disable” option.
    • We recommend updating your browsers to the latest version as there have been security updates.
    • You may also try using Compatibility View:
      • 1. To use Compatibility View:
        • a. Open the webpage in Internet Explorer, and then click Compatibility View on the Tools menu. If you do not see the Tools menu, press ALT.
        • b. When Compatibility View is turned on, the button changes from an outline to a solid color when you view the page.
      • 2. To set Compatibility View:
        • a. In Internet Explorer, click Compatibility View settings on the Tools menu. If you do not see the Tools menu, press ALT.
        • b. In the Compatibility View Settings windows, type the address of the webpage, and then click Add.

Was this helpful?: 

No